import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^u]es|ma$|mo|y|[mie]e|wi|ter|au";
final String string = "mother\n"
+ "mom\n"
+ "ma\n"
+ "daughter\n"
+ "sister\n"
+ "wife\n"
+ "grandmother\n"
+ "grandma\n"
+ "aunt\n"
+ "niece\n"
+ "queen\n"
+ "princess\n"
+ "empress\n"
+ "duchess\n"
+ "marchioness\n"
+ "countess\n"
+ "baroness\n"
+ "baronetess\n"
+ "lady\n"
+ "dame\n\n"
+ "father\n"
+ "dad\n"
+ "pa\n"
+ "son\n"
+ "brother\n"
+ "husband\n"
+ "grandfather\n"
+ "grandpa\n"
+ "uncle\n"
+ "nephew\n"
+ "king\n"
+ "prince\n"
+ "emperor\n"
+ "duke\n"
+ "marquess\n"
+ "earl\n"
+ "baron\n"
+ "baronet\n"
+ "lord\n"
+ "knight";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}