using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z0-9]+)\s+""([a-z0-9\s.]+)""\s+([a-z0-9]+)";
string input = @"1a ""2a 2.1a 2.2a"" 3a
4b ""5.5b 5.6b 5.7b"" 6b
7c 8c 9c";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}