package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z0-9]+)\s+"([a-z0-9\s.]+)"\s+([a-z0-9]+)`)
var str = `1a "2a 2.1a 2.2a" 3a
4b "5.5b 5.6b 5.7b" 6b
7c 8c 9c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}