import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z0-9]+)\\s+\"([a-z0-9\\s.]+)\"\\s+([a-z0-9]+)";
final String string = "1a \"2a 2.1a 2.2a\" 3a\n"
+ "4b \"5.5b 5.6b 5.7b\" 6b\n"
+ "7c 8c 9c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}