$re = '/([a-z0-9]+)\s+"([a-z0-9\s.]+)"\s+([a-z0-9]+)/m';
$str = '1a "2a 2.1a 2.2a" 3a
4b "5.5b 5.6b 5.7b" 6b
7c 8c 9c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);