#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)(?<=<title>)(?:.*)(Машины|Маша)(?:.*)(?=<\/title>)"
Local $sString = "<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>" & @CRLF & _
"" & @CRLF & _
"Маша уже 10 лет пользуется Head & Shoulders и она очень довольна." & @CRLF & _
"" & @CRLF & _
"<!-- А это еще один title в конце документа -->" & @CRLF & _
" " & @CRLF & _
"<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")