using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<title>)(?:.*)(Машины|Маша)(?:.*)(?=<\/title>)";
string input = @"<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>
Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.
<!-- А это еще один title в конце документа -->
<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}