$re = '/(?<=<title>)(?:.*)(Машины|Маша)(?:.*)(?=<\/title>)/iu';
$str = '<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>
Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.
<!-- А это еще один title в конце документа -->
<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);