re = /(?<=<title>)(?:.*)(Машины|Маша)(?:.*)(?=<\/title>)/i
str = '<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>
Маша уже 10 лет пользуется Head & Shoulders и она очень довольна.
<!-- А это еще один title в конце документа -->
<title>Машины волосы мягкие и шелковистые потому что Маша пользуется Head & Shoulders</title>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end