#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<script.*>|<\/script>)"
Local $sString = "<script type="text/javascript">" & @CRLF & _
" $("#apis-title").keyup(function () {" & @CRLF & _
" var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, '_');" & @CRLF & _
" $("#apis-name").val(nameText.toLowerCase());" & @CRLF & _
" });" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")