re = /(<script.*>|<\/script>)/i
str = '<script type="text/javascript">
$("#apis-title").keyup(function () {
var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, \'_\');
$("#apis-name").val(nameText.toLowerCase());
});
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end