// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(<script.*>|<\/script>)").unwrap();
let string = "<script type=\"text/javascript\">
$(\"#apis-title\").keyup(function () {
var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, '_');
$(\"#apis-name\").val(nameText.toLowerCase());
});
</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}