import re
regex = re.compile(r"(<script.*>|<\/script>)", flags=re.IGNORECASE)
test_str = ("<script type=\"text/javascript\">\n"
" $(\"#apis-title\").keyup(function () {\n"
" var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, '_');\n"
" $(\"#apis-name\").val(nameText.toLowerCase());\n"
" });\n"
"</script>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")