using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<script.*>|<\/script>)";
string input = @"<script type=""text/javascript"">
$(""#apis-title"").keyup(function () {
var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, '_');
$(""#apis-name"").val(nameText.toLowerCase());
});
</script>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}