using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=([^""\\]*(\\.|""([^""\\]*\\.)*[^""\\]*""))*[^""]*$)//.*$";
string input = @"// jkkkk ""But remove this ha ha"" kkkko909090
char * foo = ""//don't remove // really please don't"";
// ""But remove this ha ha!""
// along with this!
""//shall not be removed""
char *bad_regex_strategy = ""\""good luck\"" // \""counting the \""quotes\"" ""//\""//""; // \""ha"""" \"" "" \"" ha ha\"" ha /// ""\;""ha'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}