$re = '@(?=([^"\\\\]*(\\\\.|"([^"\\\\]*\\\\.)*[^"\\\\]*"))*[^"]*$)//.*$@m';
$str = '// jkkkk "But remove this ha ha" kkkko909090
char * foo = "//don\'t remove // really please don\'t";
// "But remove this ha ha!"
// along with this!
"//shall not be removed"
char *bad_regex_strategy = "\\"good luck\\" // \\"counting the \\"quotes\\"" "//\\"//"; // \\"ha""" \\" " \\" ha ha\\" ha /// "\\;"ha\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);