use strict;
my $str = '// jkkkk "But remove this ha ha" kkkko909090
char * foo = "//don\'t remove // really please don\'t";
// "But remove this ha ha!"
// along with this!
"//shall not be removed"
char *bad_regex_strategy = "\\"good luck\\" // \\"counting the \\"quotes\\"" "//\\"//"; // \\"ha""" \\" " \\" ha ha\\" ha /// "\\;"ha\'';
my $regex = qr@(?=([^"\\]*(\\.|"([^"\\]*\\.)*[^"\\]*"))*[^"]*$)//.*$@mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}