re = /(?=([^"\\]*(\\.|"([^"\\]*\\.)*[^"\\]*"))*[^"]*$)\/\/.*$/m
str = '// jkkkk "But remove this ha ha" kkkko909090
char * foo = "//don\'t remove // really please don\'t";
// "But remove this ha ha!"
// along with this!
"//shall not be removed"
char *bad_regex_strategy = "\\"good luck\\" // \\"counting the \\"quotes\\"" "//\\"//"; // \\"ha""" \\" " \\" ha ha\\" ha /// "\\;"ha\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end