import Foundation
let pattern = #"(?=([^"\\]*(\\.|"([^"\\]*\\.)*[^"\\]*"))*[^"]*$)//.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// jkkkk "But remove this ha ha" kkkko909090
char * foo = "//don't remove // really please don't";
// "But remove this ha ha!"
// along with this!
"//shall not be removed"
char *bad_regex_strategy = "\"good luck\" // \"counting the \"quotes\"" "//\"//"; // \"ha""" \" " \" ha ha\" ha /// "\;"ha'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)