# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S+?),(?=\S+)/$1 /mg;t' <<< "SELECT
di.QuestionSetID AS SectionID,
di.QuestionSetID AS SectionID2
,di.ScoreNBR AS Section,LowestTopBoxNBR
,di.AveragePercentileNBR AS SectionTopBoxPercentileRankNBR
,qdate.Quarter,StartDTS AS Section,StartDTS
FROM NRCPicker.PatientSatisfaction.DimensionPercentile AS di
INNER JOIN ("