const regex = /(\S+?),(?=\S+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+?),(?=\\S+)', 'mg')
const str = `SELECT
di.QuestionSetID AS SectionID,
di.QuestionSetID AS SectionID2
,di.ScoreNBR AS Section,LowestTopBoxNBR
,di.AveragePercentileNBR AS SectionTopBoxPercentileRankNBR
,qdate.Quarter,StartDTS AS Section,StartDTS
FROM NRCPicker.PatientSatisfaction.DimensionPercentile AS di
INNER JOIN (`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);