import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+?),(?=\\S+)";
final String string = "SELECT\n"
+ " di.QuestionSetID AS SectionID, \n"
+ " di.QuestionSetID AS SectionID2\n"
+ ",di.ScoreNBR AS Section,LowestTopBoxNBR\n"
+ ",di.AveragePercentileNBR AS SectionTopBoxPercentileRankNBR \n"
+ ",qdate.Quarter,StartDTS AS Section,StartDTS \n"
+ "FROM NRCPicker.PatientSatisfaction.DimensionPercentile AS di\n"
+ "INNER JOIN (";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}