# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?sx)
(?|
\\/R.\w*\\/(?=.*(\\/r\\/))
|
\\/C.\w*\\/(?=.*(\\/c\\/))
|
\\/M.\w*\\/(?=.*(\\/m\\/))
|
\\/T.\w*\\/(?=.*(\\/t\\/))
)/\1/gsx;t' <<< "/Ramon/ /Cesar/ /Murilo/ /Tiago/"