$re = '/(?sx)
(?| 
  \/R.\w*\/(?=.*(\/r\/))
  |
  \/C.\w*\/(?=.*(\/c\/))
  |
  \/M.\w*\/(?=.*(\/m\/))
  |
  \/T.\w*\/(?=.*(\/t\/))
)/sx';
$str = '/Ramon/ /Cesar/ /Murilo/ /Tiago/';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;