import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sx)\n"
+ "(?| \n"
+ " \\/R.\\w*\\/(?=.*(\\/r\\/))\n"
+ " |\n"
+ " \\/C.\\w*\\/(?=.*(\\/c\\/))\n"
+ " |\n"
+ " \\/M.\\w*\\/(?=.*(\\/m\\/))\n"
+ " |\n"
+ " \\/T.\\w*\\/(?=.*(\\/t\\/))\n"
+ ")";
final String string = "/Ramon/ /Cesar/ /Murilo/ /Tiago/";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}