using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sx)
(?|
\/R.\w*\/(?=.*(\/r\/))
|
\/C.\w*\/(?=.*(\/c\/))
|
\/M.\w*\/(?=.*(\/m\/))
|
\/T.\w*\/(?=.*(\/t\/))
)";
string substitution = @"\1";
string input = @"/Ramon/ /Cesar/ /Murilo/ /Tiago/";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}