#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ ]*([^\r\n:]+?)\s*:"
Local $sString = "define({" & @CRLF & _
" somekey : "Some {text} here:"," & @CRLF & _
" 'some-key' : "Text:"," & @CRLF & _
" 'key/key' : 'Some : text'," & @CRLF & _
" key: 'some value'," & @CRLF & _
" 'my-key' : 'my text'," & @CRLF & _
" 'my/key' : 'my topic text'" & @CRLF & _
" "my-key" : "my topic text"" & @CRLF & _
"" & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")