// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ ]*([^\r\n:]+?)\s*:").unwrap();
let string = "define({
somekey : \"Some {text} here:\",
'some-key' : \"Text:\",
'key/key' : 'Some : text',
key: 'some value',
'my-key' : 'my text',
'my/key' : 'my topic text'
\"my-key\" : \"my topic text\"
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}