package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ ]*([^\r\n:]+?)\s*:`)
var str = `define({
somekey : "Some {text} here:",
'some-key' : "Text:",
'key/key' : 'Some : text',
key: 'some value',
'my-key' : 'my text',
'my/key' : 'my topic text'
"my-key" : "my topic text"
});`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}