using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^[ ]*([^\r\n:]+?)\s*:";
string input = @"define({
somekey : ""Some {text} here:"",
'some-key' : ""Text:"",
'key/key' : 'Some : text',
key: 'some value',
'my-key' : 'my text',
'my/key' : 'my topic text'
""my-key"" : ""my topic text""
});";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}