$re = '/(?m)^[ ]*([^\r\n:]+?)\s*:/';
$str = 'define({
somekey : "Some {text} here:",
\'some-key\' : "Text:",
\'key/key\' : \'Some : text\',
key: \'some value\',
\'my-key\' : \'my text\',
\'my/key\' : \'my topic text\'
"my-key" : "my topic text"
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);