import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Run.*tripleo-container-image-prepare.log\\s*\\-?\\s*([1-9]*\\.?[1-9]*)s";
final String string = "FIRST CASE:\n\n"
+ "2019-10-02 10:59:31.725 16083 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log - 911.14s\n\n"
+ "SECOND CASE:\n\n"
+ "2019-09-30 08:51:23 | tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log 4335.64s\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}