import re
regex = re.compile(r"Run.*tripleo-container-image-prepare.log\s*\-?\s*([1-9]*\.?[1-9]*)s", flags=re.MULTILINE)
test_str = ("FIRST CASE:\n\n"
"2019-10-02 10:59:31.725 16083 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log - 911.14s\n\n"
"SECOND CASE:\n\n"
"2019-09-30 08:51:23 | tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log 4335.64s\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")