const regex = /Run.*tripleo-container-image-prepare.log\s*\-?\s*([1-9]*\.?[1-9]*)s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Run.*tripleo-container-image-prepare.log\\s*\\-?\\s*([1-9]*\\.?[1-9]*)s', 'gm')
const str = `FIRST CASE:
2019-10-02 10:59:31.725 16083 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log - 911.14s
SECOND CASE:
2019-09-30 08:51:23 | tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log 4335.64s
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}