re = /Run.*tripleo-container-image-prepare.log\s*\-?\s*([1-9]*\.?[1-9]*)s/m
str = 'FIRST CASE:
2019-10-02 10:59:31.725 16083 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log - 911.14s
SECOND CASE:
2019-09-30 08:51:23 | tripleo-container-image-prepare : Run tripleo-container-image-prepare logged to: /var/log/tripleo-container-image-prepare.log 4335.64s
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end