package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[\"\']([\a-zA-Z0-9-_]*logo[a-zA-Z0-9\-_]*\.(?:png|jpg|jpeg)).*?"`)
var str = `/example/logo.png
/example/logo_adsadsa.jpg
"/e/logo_adsada.jpg?size=400"
src="dadsadsadadadadsadasdadsadsalogosdsd.png"
<html>
<head>
<style>
someclass {
background-image: url("/css/images/logo2.jpg");"
background-color: #cccccc;
}
</style>
</head>
<body>
<h1>Hello World!</h1>
</body>
<html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}