const regex = /[\"\']([\a-zA-Z0-9-_]*logo[a-zA-Z0-9\-_]*\.(?:png|jpg|jpeg)).*?"/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\"\\\']([\\a-zA-Z0-9-_]*logo[a-zA-Z0-9\\-_]*\\.(?:png|jpg|jpeg)).*?"', 'gmi')
const str = `/example/logo.png
/example/logo_adsadsa.jpg
"/e/logo_adsada.jpg?size=400"
src="dadsadsadadadadsadasdadsadsalogosdsd.png"
<html>
<head>
<style>
someclass {
background-image: url("/css/images/logo2.jpg");"
background-color: #cccccc;
}
</style>
</head>
<body>
<h1>Hello World!</h1>
</body>
<html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}