import re
regex = re.compile(r"[\"\']([\a-zA-Z0-9-_]*logo[a-zA-Z0-9\-_]*\.(?:png|jpg|jpeg)).*?\"", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("/example/logo.png\n"
"/example/logo_adsadsa.jpg\n"
"\"/e/logo_adsada.jpg?size=400\"\n"
"src=\"dadsadsadadadadsadasdadsadsalogosdsd.png\"\n\n"
"<html>\n"
" <head>\n"
" <style>\n"
" someclass {\n"
" background-image: url(\"/css/images/logo2.jpg\");\"\n"
" background-color: #cccccc;\n"
" }\n"
" </style>\n"
" </head>\n"
" \n"
" <body>\n"
" <h1>Hello World!</h1>\n"
" </body>\n"
"<html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")