use strict;
my $str = '/example/logo.png
/example/logo_adsadsa.jpg
"/e/logo_adsada.jpg?size=400"
src="dadsadsadadadadsadasdadsadsalogosdsd.png"
<html>
<head>
<style>
someclass {
background-image: url("/css/images/logo2.jpg");"
background-color: #cccccc;
}
</style>
</head>
<body>
<h1>Hello World!</h1>
</body>
<html>';
my $regex = qr/[\"\']([\a-zA-Z0-9-_]*logo[a-zA-Z0-9\-_]*\.(?:png|jpg|jpeg)).*?"/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}