using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Claim Code:\s*([\w-]+)\s*\$(\d+(?:\.\d+)?)";
string input = @"Claim Code:
7241B-2HWRXR9-2P2BA
$1.00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}