package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Claim Code:\s*([\w-]+)\s*\$(\d+(?:\.\d+)?)`)
var str = `Claim Code:
7241B-2HWRXR9-2P2BA
$1.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}