re = /Claim Code:\s*([\w-]+)\s*\$(\d+(?:\.\d+)?)/
str = 'Claim Code:
7241B-2HWRXR9-2P2BA
$1.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end