$re = '/Claim Code:\s*([\w-]+)\s*\$(\d+(?:\.\d+)?)/';
$str = 'Claim Code:
7241B-2HWRXR9-2P2BA
$1.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);