using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"REGEXP_REPLACE('RGM:NRKM:KMLPBC02 ADD TRANSPONDER','^.*([A-Z]{4}(VU|NT|MB|YT|WA|SK|CA|NF|PE|NB|NS|ON|IN|WI|IL|MI|MN|BC|PQ|CT|MA|NY|AB)[A-Z0-9]{2}).*$','$1','m')";
string substitution = @"";
string input = @"|some=text1,text2|some=tex3,some=text3
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}