# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"REGEXP_REPLACE('RGM:NRKM:KMLPBC02 ADD TRANSPONDER','^.*([A-Z]{4}(VU|NT|MB|YT|WA|SK|CA|NF|PE|NB|NS|ON|IN|WI|IL|MI|MN|BC|PQ|CT|MA|NY|AB)[A-Z0-9]{2}).*$','$1','m')"
test_str = ("|some=text1,text2|some=tex3,some=text3\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.