import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "REGEXP_REPLACE('RGM:NRKM:KMLPBC02 ADD TRANSPONDER','^.*([A-Z]{4}(VU|NT|MB|YT|WA|SK|CA|NF|PE|NB|NS|ON|IN|WI|IL|MI|MN|BC|PQ|CT|MA|NY|AB)[A-Z0-9]{2}).*$','$1','m')";
final String string = "|some=text1,text2|some=tex3,some=text3\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}