re = /REGEXP_REPLACE('RGM:NRKM:KMLPBC02 ADD TRANSPONDER','^.*([A-Z]{4}(VU|NT|MB|YT|WA|SK|CA|NF|PE|NB|NS|ON|IN|WI|IL|MI|MN|BC|PQ|CT|MA|NY|AB)[A-Z0-9]{2}).*$','$1','m')/
str = '|some=text1,text2|some=tex3,some=text3
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result