// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"REGEXP_REPLACE('RGM:NRKM:KMLPBC02 ADD TRANSPONDER','^.*([A-Z]{4}(VU|NT|MB|YT|WA|SK|CA|NF|PE|NB|NS|ON|IN|WI|IL|MI|MN|BC|PQ|CT|MA|NY|AB)[A-Z0-9]{2}).*$','$1','m')").unwrap();
let string = "|some=text1,text2|some=tex3,some=text3
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}