const regex = /.*?(<body>.*?<\/body>).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(<body>.*?<\\\/body>).*', '')
const str = `<html><head><title></title></head><body>my content</body></html>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);