$re = '/.*?(<body>.*?<\/body>).*/';
$str = '<html><head><title></title></head><body>my content</body></html>';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;